您现在的位置是:首页 > 网站建设常见问答网站建设常见问答
PHP无法执行 phpinfo() 问题
2015-12-21【网站建设常见问答】3203 人已围观
简介今天遇到 一个问题现象: 安装完毕PHP之后,执行phpinfo()发现页面无法打开 查看apache的erro...
今天遇到 一个问题现象:
安装完毕PHP之后,执行phpinfo() 发现页面无法打开
查看apache的error.log信息,发现报错:
[Sun Apr 25 13:40:37 2010] [error] [client 192.168.0.145] PHP Warning: phpinfo() has been disabled for security reasons in /usr/local/apache2/htdocs/index.php on line 3
[Sun Apr 25 13:40:39 2010] [error] [client 192.168.0.145] File does not exist: /usr/local/apache2/htdocs/favicon.ico
这个错误很少见,phpinfo尽然无法执行,这样我都无法判断服务器php版本。头痛的
问题原因:
由于在php.ini中disable了 phpinfo 函数,所以导致了这个问题,disable是为了安全性考虑。只需要打开就可以了。
解决办法:
打开/etc/php.ini 文件
修改:
;disable_functions = phpinfo,passthru,exec,system,popen,chroot,escapeshellcmd,escapeshellarg,shell_exec,proc_open,proc_get_status,ini_restore
为:
disable_functions =
重新启动apache就可以了
关注宁波网站建设博客,更多精彩分享,敬请期待!
安装完毕PHP之后,执行phpinfo() 发现页面无法打开
查看apache的error.log信息,发现报错:
[Sun Apr 25 13:40:37 2010] [error] [client 192.168.0.145] PHP Warning: phpinfo() has been disabled for security reasons in /usr/local/apache2/htdocs/index.php on line 3
[Sun Apr 25 13:40:39 2010] [error] [client 192.168.0.145] File does not exist: /usr/local/apache2/htdocs/favicon.ico
这个错误很少见,phpinfo尽然无法执行,这样我都无法判断服务器php版本。头痛的
问题原因:
由于在php.ini中disable了 phpinfo 函数,所以导致了这个问题,disable是为了安全性考虑。只需要打开就可以了。
解决办法:
打开/etc/php.ini 文件
修改:
;disable_functions = phpinfo,passthru,exec,system,popen,chroot,escapeshellcmd,escapeshellarg,shell_exec,proc_open,proc_get_status,ini_restore
为:
disable_functions =
重新启动apache就可以了
关注宁波网站建设博客,更多精彩分享,敬请期待!
Tags:
很赞哦! ()
相关文章
随机图文
新的一年网站如何优化
每一年,搜索引擎也在改版升级算法,改变自己的内容,但是很多时候,我觉得做一定比不做好,所以网站优化的时候一定要定时更新,假设你考虑不到内容...
网页设计应该专注可用性和使用效果
使用对称的代码写法 构建响应式网站过程复杂,网站整体布局都应通过HTML和CSS代码库进行编码。在设计有关网页可用性的步骤时,强烈建议设计...linux服务器一站多域名配置apache
在一台Linux服务器下我们一般都会放多个网站,这样我们就要在建立虚拟目录。有时一个网站也需要绑定多个域名,那么我们就需要配置虚拟。...
PHP图像操作GD库学习一
在我们开发网站中,用php对图片进行操作一般很少见。殷雯工作室一般只用到GD库对验证码或者用户上传的产品图片加个水印。企业网站中...




微信收款码
支付宝收款码